Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 6

Exercițiul #653

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
(număr natural nenul)
k ← 1
m ← 1
┌cât timp n>9 execută
│┌dacă n%10=[n/10]%10 atunci
││ k ← k+1
││┌dacă k>m atunci
│││ m ← k
││└■
││altfel
││ k ← 1
│└■
│ n ← [n/10]
└■
scrie m

S-a notat cu a%b restul împărţirii numărului natural a la numărul natural nenul b şi cu [c] partea întreagă a numărului real c.

Scrieţi valoarea afişată în urma executării algoritmului dacă se citeşte numărul 81112337.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #654

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
(număr natural nenul)
k ← 1
m ← 1
┌cât timp n>9 execută
│┌dacă n%10=[n/10]%10 atunci
││ k ← k+1
││┌dacă k>m atunci
│││ m ← k
││└■
││altfel
││ k ← 1
│└■
│ n ← [n/10]
└■
scrie m

S-a notat cu a%b restul împărţirii numărului natural a la numărul natural nenul b şi cu [c] partea întreagă a numărului real c.

Scrieţi numărul de valori din intervalul [10000,99999] care să înceapă cu cifra 1, care pot fi citite pentru variabila n, astfel încât, în urma executării algoritmului, pentru fiecare dintre acestea, să se afişeze valoarea 4.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #661

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte m,n,x
    (numere natural nenule, m<n)
p ← 0
┌cât timp m<n şi p=0 execută
│┌dacă m%x=0 şi n%x=0 atunci
││ p x
││altfel
││┌dacă m%x=0 atunci
│││ n n-1
│││altfel
│││ m m+1
││└■
│└■
└■
scrie m,’ ’,n

S-a notat cu a%b restul împărţirii numărului natural a la numărul natural nenul b.

Scrieţi valorile afişate în urma executării algoritmului dacă se citesc, în această ordine, numerele 11, 30 și 7.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #814

Se consideră secvenţa de mai jos, în care toate variabilele sunt de tip întreg.

i=2;
while(.....)
{ if(x%i==0) cout<<i<<’ ’;
i=i+1;
}

Pentru a afişa în ordine crescătoare toţi divizorii pozitivi ai numărului natural nenul memorat în variabila x, cu excepţia lui 1 şi a numărului respectiv, o expresie care poate înlocui punctele de suspensie este:

Varianta 1

i>0

Varianta 2

i>=2

Varianta 3

i<=x/2

Varianta 4

i<=x

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #821

Variabilele x, y și d sunt de tip întreg și memorează câte un număr natural strict pozitiv. Indicați o expresie care poate înlocui punctele de suspensie astfel încât, în urma executării secvenței obținute, variabila d să memoreze cel mai mare divizor comun al valorilor memorate în variabilele x și y.

d=x;
if(d>y) d=y; 
while(........) 
    d=d-1;
Varianta 1

(x%d)*(y%d)!=0

Varianta 2

(x+y)%d!=0

Varianta 3

x%d!=y%d

Varianta 4

x%d+y%d!=0

Subiect Bacalaureat 2016, SN
Clasa a 9-a

Exercițiul #920

Se consideră secvenţa de cod de mai jos. În n se citește întotdeauna un număr natural care conține cel puțin o cifră pară și cel puțin o cifră impară.

    int n,cmi=100,cma=-100;
    cin>>n;
    while(n)
    {
        if(.....)
        {
            if(n%10>cma)
                cma=n%10;
        }
        else
        {
            if(n%10<cmi)
                cmi=n%10;
        }
        n/=10;
    }
    cout<<cma*cmi;

Ce expresie poate înlocui punctele de suspensie pentru ca secvența de cod de mai sus să afișeze produsul dintre cifra pară maximă din n și cifra impară minimă din n.

Varianta 1
n%2==1
Varianta 2
n%10%2==0
Varianta 3
n%10==0
Varianta 4
n/2==0
Berindeie Elena
Clasa a 9-a