Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 103

Exercițiul #638

Indicaţi expresia C/C++ care are valoarea 1 dacă şi numai dacă numărul memorat în variabila întreagă x aparţine mulţimii {2015, 2016, 2017}.

Varianta 1

x==2015 && !(x<2016 || x<2017

Varianta 2

x==2015 && !(x<2016 && x<2017)

Varianta 3

x==2015 || !(x<2016 || x>2017)

Varianta 4

x==2015 || !(x<2016 && x>2017)

Simulare Bacalaureat 2016
Clasa a 9-a

Exercițiul #652

Variabilele x, y și z sunt de tip întreg și memorează numere naturale din intervalul [1,103]. Indicați o expresie C/C++ care are valoarea 1 dacă și numai dacă valoarea variabilei x este strict mai mare decât valoarea oricăreia dintre variabilele y și z.

Varianta 1

x*y>y*z && x*z>y*z

Varianta 2

x*z>x*y && y*z>y*x

Varianta 3

y*z>x*z && y*x>z*x

Varianta 4

y*z>y*x && y*z>z*x

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #660

Variabila x este de tip întreg. Indicaţi o expresie C/C++ care are valoarea 1 dacă şi numai dacă valoarea variabilei x are exact trei cifre.

Varianta 1

x%1000==0 || x%100!=0

Varianta 2

x/1000==0 || x/100!=0

Varianta 3

x%1000==0 && x%100!=0

Varianta 4

x/1000==0 && x/100!=0

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #707

Ce rezultat are expresia C/C++ 23 % 3 / 2?

Varianta 1

0

Varianta 2

1

Varianta 3

2

Varianta 4

3

proprie
Pintescu Alina
Clasa a 9-a

Exercițiul #709

Variabilele x și y sunt de tip real. Expresia C/C++ de mai jos este echivalentă cu expresia:

!(x>0 && y>0)
Varianta 1

x<=0 || y<=0

Varianta 2

x<=0 && y<=0

Varianta 3

x>0 || y>0

Varianta 4

!(x>0) && !(y>0)

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #786

Indicaţi expresia C/C++ care are valoarea 1 dacă şi numai dacă numărul natural memorat în variabila întreagă x are exact trei cifre.

Varianta 1

x/1000==0 && x/100!=0

Varianta 2

x/1000==0 || x/100!=0

Varianta 3

x%1000==0 && x%100!=0

Varianta 4

x%1000==0 || x%100!=0

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #791

Indicaţi expresia C/C++ care are valoarea 1 dacă şi numai dacă numărul natural memorat în variabila întreagă x are exact o cifră.

Varianta 1

x%10==x

Varianta 2

x/10==x

Varianta 3

x%10==x/10

Varianta 4

(x%10)/10==x

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #796

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
    (număr natural nenul) 
┌pentru i←1,n execută
│┌pentru j←1,n execută
││┌dacă i=j sau i+j=n+1 atunci 
│││ scrie ’#’ 
│││altfel 
│││ scrie j 
││└■
│└■
└■

Scrieți ce se afișează dacă se citește numărul 3.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #797

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
    (număr natural nenul) 
┌pentru i←1,n execută
│┌pentru j←1,n execută
││┌dacă i=j sau i+j=n+1 atunci 
│││ scrie ’#’ 
│││altfel 
│││ scrie j 
││└■
│└■
└■

Scrieți un număr care poate fi citit, astfel încât, în urma executării algoritmului numărul de simboluri # afișate să fie 100.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #798

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b.

citeşte a,b
   (numere naturale, a≥2, b≥2) 
┌dacă a>b atunci 
│ x←a  
│ a←b 
│ b←x 
└■
 s←0 
┌pentru x←a,b execută
│ c←2 
│┌cât timp x%c>0 execută
││ c←c+1 
│└■
│s←s+c 
└■
scrie s 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 7, 4.

Subiect Bacalaureat 2017
Clasa a 9-a