Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 103

Exercițiul #799

Variabila x este de tip întreg. Numărul de valori întregi distincte ale lui x pentru care expresia C/C++ x/2017 are valoarea 0 este:

Varianta 1

2016

Varianta 2

2017

Varianta 3

2•2016+1

Varianta 4

2•2017+1

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #800

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a, iar cu sqrt(x) rădăcina pătrată a numărului pozitiv x.

citeşte a,b
   (numere naturale, a≤b) 
 s←0 
┌pentru x←a,b execută
│┌pentru j←1,[x/2] execută
││┌dacă x%j=0 și [sqrt(j)]*[sqrt(j)]=j atunci 
│││ s←s+j 
││└■
│└■
└■
scrie s 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 11 și 16.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #805

Expresia C/C++ 3+7/4+3 are valoarea:

Varianta 1

1

Varianta 2

5.5

Varianta 3

7

Varianta 4

7.75

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #806

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a, iar cu sqrt(x) rădăcina pătrată a numărului pozitiv x.

citeşte n 
   (număr natural nenul) 
 k←0 
 i←1 
┌cât timp i≤n execută
│ citeşte x  
│   (număr natural nenul) 
│ y←2  
│┌cât timp x>1 și x%y≠0 execută
││ y←y+1 
│└■
│┌dacă k<[x/y] atunci 
││ k←[x/y] 
│└■
│ i←i+1  
└■
 scrie k 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 4, 5, 24, 3, 45.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #810

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a.

citeşte n 
    (număr natural nenul)
 p←0 
┌pentru i←1,n execută
│ m←i 
│┌cât timp m%2=0 execută
││ m←[m/2] 
│└■
│┌dacă m=1 atunci 
││ p←i 
│└■
└■
 scrie p 

Scrieți valoarea afișată în urma executării algoritmului dacă se citește numărul 12.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #811

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a.

citeşte n 
    (număr natural nenul)
 p←0 
┌pentru i←1,n execută
│ m←i 
│┌cât timp m%2=0 execută
││ m←[m/2] 
│└■
│┌dacă m=1 atunci 
││ p←i 
│└■
└■
 scrie p 

Scrieți cel mai mic și cel mai mare număr care pot fi citite, astfel încât, pentru fiecare dintre acestea, valoarea afişată să fie 16.

Scrieți cele două valori în ordine crescătoare, separate prin exact un spațiu.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #812

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b.

citeşte m,n,x 
(numere natural nenule, m<n)
 p←0 
┌cât timp m<n şi p=0 execută
│┌dacă m%x=0 şi n%x=0 atunci 
││ p←x 
││altfel 
││┌dacă m%x=0 atunci  
│││ n←n-1 
│││altfel 
│││ m←m+1 
││└■
│└■
└■
 scrie m,’ ’,n 

Scrieți valorile afişate în urma executării algoritmului dacă se citesc, în această ordine, numerele 11, 30 și 7.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #813

O expresie C/C++ care are valoarea 1 este:

Varianta 1

ceil(6.15)<ceil(5.61)

Varianta 2

ceil(6.15)>floor(5.61)

Varianta 3

floor(6.15)<ceil(5.61)

Varianta 4

floor(6.15)<floor(5.61)

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #815

În secvenţa de instrucţiuni de mai jos toate variabilele sunt de tip întreg.

for(i=0;i<5;i++)
{ for(j=0;j<5;j++)
    if(...........)
      cout<<″1 ″;
    else
      cout<<″2 ″;
  cout<<endl;
}

Indicaţi o expresie care poate înlocui punctele de suspensie astfel încât, în urma executării secvenţei obţinute, să se afişeze pe ecran valorile din figura de mai jos, în această ordine.

1 1 1 1 1
1 2 2 2 1
1 2 2 2 1
1 2 2 2 1
1 1 1 1 1
Varianta 1

(4-i)%4==0 || (4-j)%4==0

Varianta 2

(4-i)%4==0 && (4-j)%4==0

Varianta 3

(4-i)%4!=0 || (4-j)%4!=0

Varianta 4

(4-i)%4!=0 && (4-j)%4!=0

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #817

În secvenţa de instrucţiuni de mai jos toate variabilele sunt de tip întreg.

for(i=0;i<5;i++)
{ for(j=0;j<5;j++) 
    cout<<.........;
  cout<<endl; 
}

Indicaţi o expresie care poate înlocui punctele de suspensie astfel încât, în urma executării secvenţei obţinute, să se afişeze pe ecran valorile din figura de mai jos, în această ordine.

0 0 1 1 2
0 1 1 2 2 
1 1 2 2 3 
1 2 2 3 3 
2 2 3 3 4
Varianta 1

(i-j-1)/2

Varianta 2

i+j-1)/2

Varianta 3

(i-j)/2

Varianta 4

(i+j)/2

Subiect Bacalaureat 2017, SN
Clasa a 9-a