Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 20

Exercițiul #22

Care este valoarea pe care poate să o aibă iniţial variabila întreagă x dacă, la sfârşitul executării secvenţei de mai jos, variabila întreagă y are valoarea 2?

y=0;
do{
 x=x/10;
 y=y+1;
} while(x%100==0);
Varianta 1

300

Varianta 2

5000

Varianta 3

120

Varianta 4

0

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #25

Câte atribuiri se execută, în total, în secvenţa de mai jos, dacă n şi p sunt variabile de tip întreg?

p=1; n=279;
while (n>=100)
{ p=p*10;
 n=n-100;
}
Varianta 1

4

Varianta 2

6

Varianta 3

2

Varianta 4

8

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #27

Care dintre următoarele expresii C/C++ are valoarea 1 după executarea secvenţei de
instrucţiuni de mai jos, în care toate variabilele sunt întregi?

v1=0; v2=0;
for(i=1;i<=3;i++)
{ for (j=1;j<=i;j++)
 v1=v1+1;
 for (k=i;k<=3;k++)
 v2=v2+1;
}
Varianta 1

v1>v2

Varianta 2

v1<v2

Varianta 3

v1==v2

Varianta 4

v1+v2==9

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #31

În secvenţa pseudocod de mai jos, toate variabilele memorează numere naturale. Cu ce valori pot fi înlocuite punctele de suspensie din secvenţă astfel încât, la finalul executării secvenţei să se afişeze, în acestă ordine, valorile 16 şi 41?

a←...
b←...
┌pentru i←3,7 execută
│ c←a+b; x←a; a←b; b←c
└■
scrie x,c
Varianta 1

1 şi 1

Varianta 2

3 şi 4

Varianta 3

5 şi 2

Varianta 4

2 şi 7

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #40

În următoarea secvenţă de program, instrucţiunea de afişare se va executa de un număr de ori egal cu:

for (i=1;i<=3;i++)
  for (j=10;j>=i+1;j--)
    cout<<j; | printf(”%d”,j);
Varianta 1

24

Varianta 2

21

Varianta 3

3

Varianta 4

30

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #42

În secvenţa de instrucţiuni de mai jos, variabilele x şi y sunt de tip int. Care este valoarea pe care trebuie să o aibă iniţial variabila x dacă la finalul executării secvenţei s-a afişat un singur caracter asterisc (*)?

y=x;
while(x<=3)
{
 cout<<"*"; | printf("*");
 y=y+1; x=x+y;
}
Varianta 1

0

Varianta 2

2

Varianta 3

1

Varianta 4

4

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #43

Care este valoarea pe care trebuie să o aibă iniţial variabila întreagă x pentru ca, în urma executării secvenţei de mai jos, să se afişeze HHHHHH?

while (x!=3){
  x=x-1;
  cout<<"HH"; | printf(”HH”);
}
Varianta 1

0

Varianta 2

4

Varianta 3

6

Varianta 4

5

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #45

Care este numărul total de atribuiri efectuate la executarea secvenţei de instrucţiuni de mai jos?

x=4; y=6;
while (y==6) y=y+1;
if (x==y) x=x+1;
Varianta 1

4

Varianta 2

3

Varianta 3

2

Varianta 4

5

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #796

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
    (număr natural nenul) 
┌pentru i←1,n execută
│┌pentru j←1,n execută
││┌dacă i=j sau i+j=n+1 atunci 
│││ scrie ’#’ 
│││altfel 
│││ scrie j 
││└■
│└■
└■

Scrieți ce se afișează dacă se citește numărul 3.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #797

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
    (număr natural nenul) 
┌pentru i←1,n execută
│┌pentru j←1,n execută
││┌dacă i=j sau i+j=n+1 atunci 
│││ scrie ’#’ 
│││altfel 
│││ scrie j 
││└■
│└■
└■

Scrieți un număr care poate fi citit, astfel încât, în urma executării algoritmului numărul de simboluri # afișate să fie 100.

Subiect Bacalaureat 2017
Clasa a 9-a