Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 22

Exercițiul #798

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b.

citeşte a,b
   (numere naturale, a≥2, b≥2) 
┌dacă a>b atunci 
│ x←a  
│ a←b 
│ b←x 
└■
 s←0 
┌pentru x←a,b execută
│ c←2 
│┌cât timp x%c>0 execută
││ c←c+1 
│└■
│s←s+c 
└■
scrie s 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 7, 4.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #800

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a, iar cu sqrt(x) rădăcina pătrată a numărului pozitiv x.

citeşte a,b
   (numere naturale, a≤b) 
 s←0 
┌pentru x←a,b execută
│┌pentru j←1,[x/2] execută
││┌dacă x%j=0 și [sqrt(j)]*[sqrt(j)]=j atunci 
│││ s←s+j 
││└■
│└■
└■
scrie s 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 11 și 16.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #806

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a, iar cu sqrt(x) rădăcina pătrată a numărului pozitiv x.

citeşte n 
   (număr natural nenul) 
 k←0 
 i←1 
┌cât timp i≤n execută
│ citeşte x  
│   (număr natural nenul) 
│ y←2  
│┌cât timp x>1 și x%y≠0 execută
││ y←y+1 
│└■
│┌dacă k<[x/y] atunci 
││ k←[x/y] 
│└■
│ i←i+1  
└■
 scrie k 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 4, 5, 24, 3, 45.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #810

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a.

citeşte n 
    (număr natural nenul)
 p←0 
┌pentru i←1,n execută
│ m←i 
│┌cât timp m%2=0 execută
││ m←[m/2] 
│└■
│┌dacă m=1 atunci 
││ p←i 
│└■
└■
 scrie p 

Scrieți valoarea afișată în urma executării algoritmului dacă se citește numărul 12.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #811

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a.

citeşte n 
    (număr natural nenul)
 p←0 
┌pentru i←1,n execută
│ m←i 
│┌cât timp m%2=0 execută
││ m←[m/2] 
│└■
│┌dacă m=1 atunci 
││ p←i 
│└■
└■
 scrie p 

Scrieți cel mai mic și cel mai mare număr care pot fi citite, astfel încât, pentru fiecare dintre acestea, valoarea afişată să fie 16.

Scrieți cele două valori în ordine crescătoare, separate prin exact un spațiu.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #812

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b.

citeşte m,n,x 
(numere natural nenule, m<n)
 p←0 
┌cât timp m<n şi p=0 execută
│┌dacă m%x=0 şi n%x=0 atunci 
││ p←x 
││altfel 
││┌dacă m%x=0 atunci  
│││ n←n-1 
│││altfel 
│││ m←m+1 
││└■
│└■
└■
 scrie m,’ ’,n 

Scrieți valorile afişate în urma executării algoritmului dacă se citesc, în această ordine, numerele 11, 30 și 7.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #815

În secvenţa de instrucţiuni de mai jos toate variabilele sunt de tip întreg.

for(i=0;i<5;i++)
{ for(j=0;j<5;j++)
    if(...........)
      cout<<″1 ″;
    else
      cout<<″2 ″;
  cout<<endl;
}

Indicaţi o expresie care poate înlocui punctele de suspensie astfel încât, în urma executării secvenţei obţinute, să se afişeze pe ecran valorile din figura de mai jos, în această ordine.

1 1 1 1 1
1 2 2 2 1
1 2 2 2 1
1 2 2 2 1
1 1 1 1 1
Varianta 1

(4-i)%4==0 || (4-j)%4==0

Varianta 2

(4-i)%4==0 && (4-j)%4==0

Varianta 3

(4-i)%4!=0 || (4-j)%4!=0

Varianta 4

(4-i)%4!=0 && (4-j)%4!=0

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #817

În secvenţa de instrucţiuni de mai jos toate variabilele sunt de tip întreg.

for(i=0;i<5;i++)
{ for(j=0;j<5;j++) 
    cout<<.........;
  cout<<endl; 
}

Indicaţi o expresie care poate înlocui punctele de suspensie astfel încât, în urma executării secvenţei obţinute, să se afişeze pe ecran valorile din figura de mai jos, în această ordine.

0 0 1 1 2
0 1 1 2 2 
1 1 2 2 3 
1 2 2 3 3 
2 2 3 3 4
Varianta 1

(i-j-1)/2

Varianta 2

i+j-1)/2

Varianta 3

(i-j)/2

Varianta 4

(i+j)/2

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #977

În secvențele de mai jos, notate cu S1, S2 și S3, toate variabilele sunt întregi, iar variabila n memorează un număr natural cu cel mult nouă cifre.

//S1
if(n==0) p=1; 
else 
  if (n%2==0) p=6; 
  else p=4;
//S2
p=1; 
for(i=1;i<=n;i++) 
  p=(p*4)%10;
//S3
p=1; 
for(i=1;i<=n;i++) 
  p=(p%10)*4;

Variabila p memorează ultima cifră a numărului 4n în urma execut
ării, independent, a secvențelor:

Varianta 1

S1 și S2

Varianta 2

S1 și S3

Varianta 3

S2 și S3

Varianta 4

S1, S2 și S3

Subiect Bacalaureat 2018, sesiunea iunie-iulie, științele naturii
Clasa a 9-a

Exercițiul #995

Indicați expresia C/C++ cu valoarea 1.

Varianta 1

21/3*19==3/19*21

Varianta 2

21/19*3==19/3*21

Varianta 3

19/3*21==3/21*19

Varianta 4

19/21*3==3/19*21

Subiect simulare Bacalaureat 2019
Clasa a 9-a