Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 16

Exercițiul #821

Variabilele x, y și d sunt de tip întreg și memorează câte un număr natural strict pozitiv. Indicați o expresie care poate înlocui punctele de suspensie astfel încât, în urma executării secvenței obținute, variabila d să memoreze cel mai mare divizor comun al valorilor memorate în variabilele x și y.

d=x;
if(d>y) d=y; 
while(........) 
    d=d-1;
Varianta 1

(x%d)*(y%d)!=0

Varianta 2

(x+y)%d!=0

Varianta 3

x%d!=y%d

Varianta 4

x%d+y%d!=0

Subiect Bacalaureat 2016, SN
Clasa a 9-a

Exercițiul #820

Indicați o expresie C/C++ care are valoarea 1 dacă și numai dacă numărul întreg memorat în variabila întreagă x aparține mulțimii {-2,-1,1,2}.

Varianta 1

abs(x)>2 || x==0

Varianta 2

abs(x)<=2 && x!=0

Varianta 3

abs(x-2)<1

Varianta 4

abs(x-1)>2

Subiect Bacalaureat 2016, SN
Clasa a 9-a

Exercițiul #812

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b.

citeşte m,n,x 
(numere natural nenule, m<n)
 p←0 
┌cât timp m<n şi p=0 execută
│┌dacă m%x=0 şi n%x=0 atunci 
││ p←x 
││altfel 
││┌dacă m%x=0 atunci  
│││ n←n-1 
│││altfel 
│││ m←m+1 
││└■
│└■
└■
 scrie m,’ ’,n 

Scrieți valorile afişate în urma executării algoritmului dacă se citesc, în această ordine, numerele 11, 30 și 7.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #811

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a.

citeşte n 
    (număr natural nenul)
 p←0 
┌pentru i←1,n execută
│ m←i 
│┌cât timp m%2=0 execută
││ m←[m/2] 
│└■
│┌dacă m=1 atunci 
││ p←i 
│└■
└■
 scrie p 

Scrieți cel mai mic și cel mai mare număr care pot fi citite, astfel încât, pentru fiecare dintre acestea, valoarea afişată să fie 16.

Scrieți cele două valori în ordine crescătoare, separate prin exact un spațiu.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #810

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a.

citeşte n 
    (număr natural nenul)
 p←0 
┌pentru i←1,n execută
│ m←i 
│┌cât timp m%2=0 execută
││ m←[m/2] 
│└■
│┌dacă m=1 atunci 
││ p←i 
│└■
└■
 scrie p 

Scrieți valoarea afișată în urma executării algoritmului dacă se citește numărul 12.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #709

Variabilele x și y sunt de tip real. Expresia C/C++ de mai jos este echivalentă cu expresia:

!(x>0 && y>0)
Varianta 1

x<=0 || y<=0

Varianta 2

x<=0 && y<=0

Varianta 3

x>0 || y>0

Varianta 4

!(x>0) && !(y>0)

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #661

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte m,n,x
    (numere natural nenule, m<n)
p ← 0
┌cât timp m<n şi p=0 execută
│┌dacă m%x=0 şi n%x=0 atunci
││ p x
││altfel
││┌dacă m%x=0 atunci
│││ n n-1
│││altfel
│││ m m+1
││└■
│└■
└■
scrie m,’ ’,n

S-a notat cu a%b restul împărţirii numărului natural a la numărul natural nenul b.

Scrieţi valorile afişate în urma executării algoritmului dacă se citesc, în această ordine, numerele 11, 30 și 7.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #660

Variabila x este de tip întreg. Indicaţi o expresie C/C++ care are valoarea 1 dacă şi numai dacă valoarea variabilei x are exact trei cifre.

Varianta 1

x%1000==0 || x%100!=0

Varianta 2

x/1000==0 || x/100!=0

Varianta 3

x%1000==0 && x%100!=0

Varianta 4

x/1000==0 && x/100!=0

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #655

Variabilele i şi j sunt de tip întreg, iar variabila m memorează un tablou bidimensional cu 5 linii şi 5 coloane, numerotate de la 0 la 4, cu elemente numere întregi.

O expresie C/C++ a cărei valoare este egală cu produsul dintre primul element de pe linia i și ultimul element de pe coloana j din acest tablou este:

Varianta 1

m[0,i]*m[j,4]

Varianta 2

m(0,i)*m(j,4)

Varianta 3

m(i)(0)*m(4)(j)

Varianta 4

m[i][0]*m[4][j]

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #654

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
(număr natural nenul)
k ← 1
m ← 1
┌cât timp n>9 execută
│┌dacă n%10=[n/10]%10 atunci
││ k ← k+1
││┌dacă k>m atunci
│││ m ← k
││└■
││altfel
││ k ← 1
│└■
│ n ← [n/10]
└■
scrie m

S-a notat cu a%b restul împărţirii numărului natural a la numărul natural nenul b şi cu [c] partea întreagă a numărului real c.

Scrieţi numărul de valori din intervalul [10000,99999] care să înceapă cu cifra 1, care pot fi citite pentru variabila n, astfel încât, în urma executării algoritmului, pentru fiecare dintre acestea, să se afişeze valoarea 4.

Subiect Bacalaureat 2016
Clasa a 9-a