Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 16

Exercițiul #820

Indicați o expresie C/C++ care are valoarea 1 dacă și numai dacă numărul întreg memorat în variabila întreagă x aparține mulțimii {-2,-1,1,2}.

Varianta 1

abs(x)>2 || x==0

Varianta 2

abs(x)<=2 && x!=0

Varianta 3

abs(x-2)<1

Varianta 4

abs(x-1)>2

Subiect Bacalaureat 2016, SN
Clasa a 9-a

Exercițiul #709

Variabilele x și y sunt de tip real. Expresia C/C++ de mai jos este echivalentă cu expresia:

!(x>0 && y>0)
Varianta 1

x<=0 || y<=0

Varianta 2

x<=0 && y<=0

Varianta 3

x>0 || y>0

Varianta 4

!(x>0) && !(y>0)

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #660

Variabila x este de tip întreg. Indicaţi o expresie C/C++ care are valoarea 1 dacă şi numai dacă valoarea variabilei x are exact trei cifre.

Varianta 1

x%1000==0 || x%100!=0

Varianta 2

x/1000==0 || x/100!=0

Varianta 3

x%1000==0 && x%100!=0

Varianta 4

x/1000==0 && x/100!=0

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #652

Variabilele x, y și z sunt de tip întreg și memorează numere naturale din intervalul [1,103]. Indicați o expresie C/C++ care are valoarea 1 dacă și numai dacă valoarea variabilei x este strict mai mare decât valoarea oricăreia dintre variabilele y și z.

Varianta 1

x*y>y*z && x*z>y*z

Varianta 2

x*z>x*y && y*z>y*x

Varianta 3

y*z>x*z && y*x>z*x

Varianta 4

y*z>y*x && y*z>z*x

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #638

Indicaţi expresia C/C++ care are valoarea 1 dacă şi numai dacă numărul memorat în variabila întreagă x aparţine mulţimii {2015, 2016, 2017}.

Varianta 1

x==2015 && !(x<2016 || x<2017)

Varianta 2

x==2015 && !(x<2016 && x<2017)

Varianta 3

x==2015 || !(x<2016 || x>2017)

Varianta 4

x==2015 || !(x<2016 && x>2017)

Simulare Bacalaureat 2016
Clasa a 9-a

Exercițiul #810

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a.

citeşte n 
    (număr natural nenul)
 p←0 
┌pentru i←1,n execută
│ m←i 
│┌cât timp m%2=0 execută
││ m←[m/2] 
│└■
│┌dacă m=1 atunci 
││ p←i 
│└■
└■
 scrie p 

Scrieți valoarea afișată în urma executării algoritmului dacă se citește numărul 12.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #811

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a.

citeşte n 
    (număr natural nenul)
 p←0 
┌pentru i←1,n execută
│ m←i 
│┌cât timp m%2=0 execută
││ m←[m/2] 
│└■
│┌dacă m=1 atunci 
││ p←i 
│└■
└■
 scrie p 

Scrieți cel mai mic și cel mai mare număr care pot fi citite, astfel încât, pentru fiecare dintre acestea, valoarea afişată să fie 16.

Scrieți cele două valori în ordine crescătoare, separate prin exact un spațiu.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #812

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b.

citeşte m,n,x 
(numere natural nenule, m<n)
 p←0 
┌cât timp m<n şi p=0 execută
│┌dacă m%x=0 şi n%x=0 atunci 
││ p←x 
││altfel 
││┌dacă m%x=0 atunci  
│││ n←n-1 
│││altfel 
│││ m←m+1 
││└■
│└■
└■
 scrie m,’ ’,n 

Scrieți valorile afişate în urma executării algoritmului dacă se citesc, în această ordine, numerele 11, 30 și 7.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #653

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
(număr natural nenul)
k ← 1
m ← 1
┌cât timp n>9 execută
│┌dacă n%10=[n/10]%10 atunci
││ k ← k+1
││┌dacă k>m atunci
│││ m ← k
││└■
││altfel
││ k ← 1
│└■
│ n ← [n/10]
└■
scrie m

S-a notat cu a%b restul împărţirii numărului natural a la numărul natural nenul b şi cu [c] partea întreagă a numărului real c.

Scrieţi valoarea afişată în urma executării algoritmului dacă se citeşte numărul 81112337.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #654

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
(număr natural nenul)
k ← 1
m ← 1
┌cât timp n>9 execută
│┌dacă n%10=[n/10]%10 atunci
││ k ← k+1
││┌dacă k>m atunci
│││ m ← k
││└■
││altfel
││ k ← 1
│└■
│ n ← [n/10]
└■
scrie m

S-a notat cu a%b restul împărţirii numărului natural a la numărul natural nenul b şi cu [c] partea întreagă a numărului real c.

Scrieţi numărul de valori din intervalul [10000,99999] care să înceapă cu cifra 1, care pot fi citite pentru variabila n, astfel încât, în urma executării algoritmului, pentru fiecare dintre acestea, să se afişeze valoarea 4.

Subiect Bacalaureat 2016
Clasa a 9-a