Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 3

Exercițiul #653

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
(număr natural nenul)
k ← 1
m ← 1
┌cât timp n>9 execută
│┌dacă n%10=[n/10]%10 atunci
││ k ← k+1
││┌dacă k>m atunci
│││ m ← k
││└■
││altfel
││ k ← 1
│└■
│ n ← [n/10]
└■
scrie m

S-a notat cu a%b restul împărţirii numărului natural a la numărul natural nenul b şi cu [c] partea întreagă a numărului real c.

Scrieţi valoarea afişată în urma executării algoritmului dacă se citeşte numărul 81112337.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #654

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
(număr natural nenul)
k ← 1
m ← 1
┌cât timp n>9 execută
│┌dacă n%10=[n/10]%10 atunci
││ k ← k+1
││┌dacă k>m atunci
│││ m ← k
││└■
││altfel
││ k ← 1
│└■
│ n ← [n/10]
└■
scrie m

S-a notat cu a%b restul împărţirii numărului natural a la numărul natural nenul b şi cu [c] partea întreagă a numărului real c.

Scrieţi numărul de valori din intervalul [10000,99999] care să înceapă cu cifra 1, care pot fi citite pentru variabila n, astfel încât, în urma executării algoritmului, pentru fiecare dintre acestea, să se afişeze valoarea 4.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #583

Pentru funcţiile f1 şi f2 definite mai jos, stabiliţi care este valoarea lui f1(3). Dar f2(41382)?

long f1(int c)
{ if (c%2==1) return 1;
  else return 2;
}
long f2(long n)
{ if (n==0) return 0;
  else return f1(n%10)+f2(n/10);
}

Scrieți cele două valori în ordine, separate prin exact un spațiu!

Subiect Bacalaureat 2009
Clasa a 10-a