Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 23

Exercițiul #806

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a, iar cu sqrt(x) rădăcina pătrată a numărului pozitiv x.

citeşte n 
   (număr natural nenul) 
 k←0 
 i←1 
┌cât timp i≤n execută
│ citeşte x  
│   (număr natural nenul) 
│ y←2  
│┌cât timp x>1 și x%y≠0 execută
││ y←y+1 
│└■
│┌dacă k<[x/y] atunci 
││ k←[x/y] 
│└■
│ i←i+1  
└■
 scrie k 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 4, 5, 24, 3, 45.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #805

Expresia C/C++ 3+7/4+3 are valoarea:

Varianta 1

1

Varianta 2

5.5

Varianta 3

7

Varianta 4

7.75

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #815

În secvenţa de instrucţiuni de mai jos toate variabilele sunt de tip întreg.

for(i=0;i<5;i++)
{ for(j=0;j<5;j++)
    if(...........)
      cout<<″1 ″;
    else
      cout<<″2 ″;
  cout<<endl;
}

Indicaţi o expresie care poate înlocui punctele de suspensie astfel încât, în urma executării secvenţei obţinute, să se afişeze pe ecran valorile din figura de mai jos, în această ordine.

1 1 1 1 1
1 2 2 2 1
1 2 2 2 1
1 2 2 2 1
1 1 1 1 1
Varianta 1

(4-i)%4==0 || (4-j)%4==0

Varianta 2

(4-i)%4==0 && (4-j)%4==0

Varianta 3

(4-i)%4!=0 || (4-j)%4!=0

Varianta 4

(4-i)%4!=0 && (4-j)%4!=0

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #799

Variabila x este de tip întreg. Numărul de valori întregi distincte ale lui x pentru care expresia C/C++ x/2017 are valoarea 0 este:

Varianta 1

2016

Varianta 2

2017

Varianta 3

2•2016+1

Varianta 4

2•2017+1

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #817

În secvenţa de instrucţiuni de mai jos toate variabilele sunt de tip întreg.

for(i=0;i<5;i++)
{ for(j=0;j<5;j++) 
    cout<<.........;
  cout<<endl; 
}

Indicaţi o expresie care poate înlocui punctele de suspensie astfel încât, în urma executării secvenţei obţinute, să se afişeze pe ecran valorile din figura de mai jos, în această ordine.

0 0 1 1 2
0 1 1 2 2 
1 1 2 2 3 
1 2 2 3 3 
2 2 3 3 4
Varianta 1

(i-j-1)/2

Varianta 2

i+j-1)/2

Varianta 3

(i-j)/2

Varianta 4

(i+j)/2

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #791

Indicaţi expresia C/C++ care are valoarea 1 dacă şi numai dacă numărul natural memorat în variabila întreagă x are exact o cifră.

Varianta 1

x%10==x

Varianta 2

x/10==x

Varianta 3

x%10==x/10

Varianta 4

(x%10)/10==x

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #813

O expresie C/C++ care are valoarea 1 este:

Varianta 1

ceil(6.15)<ceil(5.61)

Varianta 2

ceil(6.15)>floor(5.61)

Varianta 3

floor(6.15)<ceil(5.61)

Varianta 4

floor(6.15)<floor(5.61)

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #786

Indicaţi expresia C/C++ care are valoarea 1 dacă şi numai dacă numărul natural memorat în variabila întreagă x are exact trei cifre.

Varianta 1

x/1000==0 && x/100!=0

Varianta 2

x/1000==0 || x/100!=0

Varianta 3

x%1000==0 && x%100!=0

Varianta 4

x%1000==0 || x%100!=0

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #814

Se consideră secvenţa de mai jos, în care toate variabilele sunt de tip întreg.

i=2;
while(.....)
{ if(x%i==0) cout<<i<<’ ’;
i=i+1;
}

Pentru a afişa în ordine crescătoare toţi divizorii pozitivi ai numărului natural nenul memorat în variabila x, cu excepţia lui 1 şi a numărului respectiv, o expresie care poate înlocui punctele de suspensie este:

Varianta 1

i>0

Varianta 2

i>=2

Varianta 3

i<=x/2

Varianta 4

i<=x

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #796

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
    (număr natural nenul) 
┌pentru i←1,n execută
│┌pentru j←1,n execută
││┌dacă i=j sau i+j=n+1 atunci 
│││ scrie ’#’ 
│││altfel 
│││ scrie j 
││└■
│└■
└■

Scrieți ce se afișează dacă se citește numărul 3.

Subiect Bacalaureat 2017
Clasa a 9-a