Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 23

Exercițiul #786

Indicaţi expresia C/C++ care are valoarea 1 dacă şi numai dacă numărul natural memorat în variabila întreagă x are exact trei cifre.

Varianta 1

x/1000==0 && x/100!=0

Varianta 2

x/1000==0 || x/100!=0

Varianta 3

x%1000==0 && x%100!=0

Varianta 4

x%1000==0 || x%100!=0

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #805

Expresia C/C++ 3+7/4+3 are valoarea:

Varianta 1

1

Varianta 2

5.5

Varianta 3

7

Varianta 4

7.75

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #806

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a, iar cu sqrt(x) rădăcina pătrată a numărului pozitiv x.

citeşte n 
   (număr natural nenul) 
 k←0 
 i←1 
┌cât timp i≤n execută
│ citeşte x  
│   (număr natural nenul) 
│ y←2  
│┌cât timp x>1 și x%y≠0 execută
││ y←y+1 
│└■
│┌dacă k<[x/y] atunci 
││ k←[x/y] 
│└■
│ i←i+1  
└■
 scrie k 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 4, 5, 24, 3, 45.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #813

O expresie C/C++ care are valoarea 1 este:

Varianta 1

ceil(6.15)<ceil(5.61)

Varianta 2

ceil(6.15)>floor(5.61)

Varianta 3

floor(6.15)<ceil(5.61)

Varianta 4

floor(6.15)<floor(5.61)

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #814

Se consideră secvenţa de mai jos, în care toate variabilele sunt de tip întreg.

i=2;
while(.....)
{ if(x%i==0) cout<<i<<’ ’;
i=i+1;
}

Pentru a afişa în ordine crescătoare toţi divizorii pozitivi ai numărului natural nenul memorat în variabila x, cu excepţia lui 1 şi a numărului respectiv, o expresie care poate înlocui punctele de suspensie este:

Varianta 1

i>0

Varianta 2

i>=2

Varianta 3

i<=x/2

Varianta 4

i<=x

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #815

În secvenţa de instrucţiuni de mai jos toate variabilele sunt de tip întreg.

for(i=0;i<5;i++)
{ for(j=0;j<5;j++)
    if(...........)
      cout<<″1 ″;
    else
      cout<<″2 ″;
  cout<<endl;
}

Indicaţi o expresie care poate înlocui punctele de suspensie astfel încât, în urma executării secvenţei obţinute, să se afişeze pe ecran valorile din figura de mai jos, în această ordine.

1 1 1 1 1
1 2 2 2 1
1 2 2 2 1
1 2 2 2 1
1 1 1 1 1
Varianta 1

(4-i)%4==0 || (4-j)%4==0

Varianta 2

(4-i)%4==0 && (4-j)%4==0

Varianta 3

(4-i)%4!=0 || (4-j)%4!=0

Varianta 4

(4-i)%4!=0 && (4-j)%4!=0

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #816

Se consideră două tablouri unidimensionale A și B: A=(1,7,9) și B=(5,7,8,12).

Determinaţi elementele unui tablou obținut prin interclasarea tablourilor A și B.

Scrieţi elementele tabloului determinat în ordinea din acesta, separate prin exact un spaţiu.

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #817

În secvenţa de instrucţiuni de mai jos toate variabilele sunt de tip întreg.

for(i=0;i<5;i++)
{ for(j=0;j<5;j++) 
    cout<<.........;
  cout<<endl; 
}

Indicaţi o expresie care poate înlocui punctele de suspensie astfel încât, în urma executării secvenţei obţinute, să se afişeze pe ecran valorile din figura de mai jos, în această ordine.

0 0 1 1 2
0 1 1 2 2 
1 1 2 2 3 
1 2 2 3 3 
2 2 3 3 4
Varianta 1

(i-j-1)/2

Varianta 2

i+j-1)/2

Varianta 3

(i-j)/2

Varianta 4

(i+j)/2

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #818

Indicați expresia C/C++ care are valoarea 1 dacă și numai dacă numărul întreg memorat în variabila întreagă x aparține reuniunii de intervale [-4,-2] ∪ [2,4].

Varianta 1

abs(x)<=4 && abs(x)%2==0

Varianta 2

abs(x)>=2 && abs(x)<=4

Varianta 3

abs(x-2)<=4

Varianta 4

abs(x-2)>=2

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #819

Variabile x și y sunt de tip întreg și memorează numere naturale nenule. Indicați instrucțiunea care poate înlocui punctele de suspensie, astfel încât în urma executării secvenței obţinute să se interschimbe valorile inițiale ale variabilelor x și y.

......
y=x/y; 
x=x/y;
Varianta 1

x=x*y;

Varianta 2

x=y/x;

Varianta 3

y=x*y;

Varianta 4

y=y/x;

Subiect Bacalaureat 2017, SN
Clasa a 9-a