Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 862

Exercițiul #476

Indicați expresia C/C++ care are valoarea 1 dacă şi numai dacă numărul natural memorat în variabila întreagă n este divizibil cu 2, dar NU şi cu 5.

Varianta 1

(n%10==0) && (n%2==0)

Varianta 2

(n%2==0) && (n%5==0)

Varianta 3

(n%10==0) || (n%5!=0)

Varianta 4

!((n%2==1) || (n%5==0))

Subiect Bacalaureat 2015
Clasa a 9-a

Exercițiul #482

Variabila întreagă x memorează un număr natural cu cel puțin patru cifre nenule distincte. Expresia C/C++ a cărei valoare este egală cu cifra sutelor acestui număr este:

Varianta 1

x/100

Varianta 2

x%100

Varianta 3

(x/10)%10

Varianta 4

(x/100)%10

Subiect Bacalaureat 2015
Clasa a 9-a

Exercițiul #275

Fie a o matrice cu 5 linii şi 5 coloane numerotate de la 1 la 5. Pentru fiecare element a[i][j] (1≤i≤5, 1≤j≤5) expresia a[i][j]==(i-1)*5+j este nenulă. Care este valoarea sumei elementelor de pe diagonala secundară a matricei?

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #800

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a, iar cu sqrt(x) rădăcina pătrată a numărului pozitiv x.

citeşte a,b
   (numere naturale, a≤b) 
 s←0 
┌pentru x←a,b execută
│┌pentru j←1,[x/2] execută
││┌dacă x%j=0 și [sqrt(j)]*[sqrt(j)]=j atunci 
│││ s←s+j 
││└■
│└■
└■
scrie s 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 11 și 16.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #799

Variabila x este de tip întreg. Numărul de valori întregi distincte ale lui x pentru care expresia C/C++ x/2017 are valoarea 0 este:

Varianta 1

2016

Varianta 2

2017

Varianta 3

2•2016+1

Varianta 4

2•2017+1

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #260

Considerăm următoarele declarări:

int i,aux,a[10][10];

Ce valori se afişează în urma executării secvenţei de mai jos dacă liniile şi
coloanele tabloului bidimensional sunt numerotate de la 0 la 9 şi iniţial fiecare linie a tabloului conţine, de la stânga la dreapta, în ordine descrescătoare, toate numerele naturale, de la 10 la 1

for (i=0;i<=8;i++)
  if( a[i][9-i]<a[i+1][8-i])
  { aux=a[i][9-i];
    a[i][9-i]=a[i+1][8-i];
    a[i+1][8-i]=aux;}
cout<<a[0][9]<<" "<<a[9][0];
Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #798

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b.

citeşte a,b
   (numere naturale, a≥2, b≥2) 
┌dacă a>b atunci 
│ x←a  
│ a←b 
│ b←x 
└■
 s←0 
┌pentru x←a,b execută
│ c←2 
│┌cât timp x%c>0 execută
││ c←c+1 
│└■
│s←s+c 
└■
scrie s 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 7, 4.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #797

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
    (număr natural nenul) 
┌pentru i←1,n execută
│┌pentru j←1,n execută
││┌dacă i=j sau i+j=n+1 atunci 
│││ scrie ’#’ 
│││altfel 
│││ scrie j 
││└■
│└■
└■

Scrieți un număr care poate fi citit, astfel încât, în urma executării algoritmului numărul de simboluri # afișate să fie 100.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #796

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
    (număr natural nenul) 
┌pentru i←1,n execută
│┌pentru j←1,n execută
││┌dacă i=j sau i+j=n+1 atunci 
│││ scrie ’#’ 
│││altfel 
│││ scrie j 
││└■
│└■
└■

Scrieți ce se afișează dacă se citește numărul 3.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #488

Expresia C/C++ 4+5%7*2 are valoarea:

Varianta 1

4

Varianta 2

8

Varianta 3

9

Varianta 4

14

Subiect Bacalaureat 2015
Clasa a 9-a