Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 5

Exercițiul #661

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte m,n,x
    (numere natural nenule, m<n)
p ← 0
┌cât timp m<n şi p=0 execută
│┌dacă m%x=0 şi n%x=0 atunci
││ p x
││altfel
││┌dacă m%x=0 atunci
│││ n n-1
│││altfel
│││ m m+1
││└■
│└■
└■
scrie m,’ ’,n

S-a notat cu a%b restul împărţirii numărului natural a la numărul natural nenul b.

Scrieţi valorile afişate în urma executării algoritmului dacă se citesc, în această ordine, numerele 11, 30 și 7.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #814

Se consideră secvenţa de mai jos, în care toate variabilele sunt de tip întreg.

i=2;
while(.....)
{ if(x%i==0) cout<<i<<’ ’;
i=i+1;
}

Pentru a afişa în ordine crescătoare toţi divizorii pozitivi ai numărului natural nenul memorat în variabila x, cu excepţia lui 1 şi a numărului respectiv, o expresie care poate înlocui punctele de suspensie este:

Varianta 1

i>0

Varianta 2

i>=2

Varianta 3

i<=x/2

Varianta 4

i<=x

Subiect Bacalaureat 2017, SN
Clasa a 9-a

Exercițiul #821

Variabilele x, y și d sunt de tip întreg și memorează câte un număr natural strict pozitiv. Indicați o expresie care poate înlocui punctele de suspensie astfel încât, în urma executării secvenței obținute, variabila d să memoreze cel mai mare divizor comun al valorilor memorate în variabilele x și y.

d=x;
if(d>y) d=y; 
while(........) 
    d=d-1;
Varianta 1

(x%d)*(y%d)!=0

Varianta 2

(x+y)%d!=0

Varianta 3

x%d!=y%d

Varianta 4

x%d+y%d!=0

Subiect Bacalaureat 2016, SN
Clasa a 9-a

Exercițiul #481

Subprogramul F este definit mai jos.

void F (int n, int d)
{ if(d<n/2) F(n, d+1);
  if(n%d==0)
  cout<<d<<’ ’;
}

Prin care dintre instrucţiunile următoare se poate apela subprogramul pentru a afişa, în ordine strict descrescătoare, toţi divizorii pozitivi proprii ai numărului 2015 (divizori naturali diferiți de 1 și de 2015).

Varianta 1
F(2015,2015);
Varianta 2
F(2015,1);
Varianta 3
F(2015,2);
Varianta 4
F(2015,d);
Subiect Bacalaureat 2015
Clasa a 10-a

Exercițiul #548

Se consideră subprogramule C/C++ recursive C1 și C2, definite mai jos.

int C1 (int a, int b)
{ if(a==b) return a;
  else if(a>b) return C1(a-b,b);
       else return C1(a,b-a);
}
int C2 (int a, int b)
{ if(b==0) return a;
  else return C2(b,a%b);
}

La apel, returnează valoarea celui mai mare divizor comun al celor două numere naturale nenule primite ca parametri:

Varianta 1

numai C1

Varianta 2

numai C2

Varianta 3

atât C1 cât şi C2

Varianta 4

nici C1 nici C2

Subiect Bacalaureat 2011
Clasa a 10-a