Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 433

Exercițiul #15

Care dintre expresiile C/C++ de mai jos este echivalentă cu următoarea expresie ((a>3) && (a<15)) || (a!=b)?

Varianta 1

((a>3) || (a<15)) && (a==b)

Varianta 2

!((a<=3) || (a>=15)) || (a!=b)

Varianta 3

((a>3) || (a<15)) && (a!=b)

Varianta 4

!(a<3 || a>15) && (a!=b)

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #36

Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă numărul natural memorat de variabila x de tip int are exact două cifre?

Varianta 1

x/100==0

Varianta 2

x/100==0 && x%10==0

Varianta 3

x/10!=0

Varianta 4

x/100==0 && x/10!=0

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #56

Variabilele a şi b sunt de tip int, iar variabilele c şi d sunt de tip double. Care dintre următoarele instrucţiuni de atribuire nu este corectă din punct de vedere sintactic?

Varianta 1

c=d+2*c;

Varianta 2

c=2-d%2*a;

Varianta 3

c=sqrt(b*b);

Varianta 4

b=(d<=c);

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #799

Variabila x este de tip întreg. Numărul de valori întregi distincte ale lui x pentru care expresia C/C++ x/2017 are valoarea 0 este:

Varianta 1

2016

Varianta 2

2017

Varianta 3

2•2016+1

Varianta 4

2•2017+1

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #509

Indicaţi expresia care are valoarea 1 dacă şi numai dacă numărul natural memorat în variabila întreagă x are exact două cifre.

Varianta 1

x/100==0 && x>9

Varianta 2

x/100==0 || x<10

Varianta 3

x%100==0 && x<100

Varianta 4

x%100==0 || x>9

Subiect Bacalaureat 2013
Clasa a 9-a

Exercițiul #797

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
    (număr natural nenul) 
┌pentru i←1,n execută
│┌pentru j←1,n execută
││┌dacă i=j sau i+j=n+1 atunci 
│││ scrie ’#’ 
│││altfel 
│││ scrie j 
││└■
│└■
└■

Scrieți un număr care poate fi citit, astfel încât, în urma executării algoritmului numărul de simboluri # afișate să fie 100.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #978

Se consideră două tablouri unidimensionale A și B: A=(21,18,14,11,4) , iar B=(46,17,14,8,3). În urma interclasării lor în ordine descrescătoare se obține tabloul cu elementele:

Varianta 1

(46,18,14,11,4)

Varianta 2

(46,21,17,18,14,14,8,11,3,4)

Varianta 3

(46,21,18,17,14,14,11,8,4,3)

Varianta 4

(46,21,18,17,14,14,8,11,4,3)

Subiect Bacalaureat 2018, sesiunea iunie-iulie, științele naturii
Clasa a 9-a

Exercițiul #253

În secvenţa de program următoare, variabila a memorează elementele unui tablou
bidimensional cu 5 linii (numerotate de la 1 la 5) şi 5 coloane (numerotate de la 1 la 5), iar celelalte variabile sunt de tip întreg.

x=0;
for (i=1;i<=5;i++)
  if(a[i][i]%2!=0)
    x=x+a[i][6-i];
      cout<<x;

Ce valoare se va afişa în urma executării secvenţei dacă se prelucrează tabloul bidimensional de mai jos?

1 2 3 4 2
6 7 8 9 4
1 2 0 4 3
7 2 1 4 5
1 2 3 4 5
Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #995

Indicați expresia C/C++ cu valoarea 1.

Varianta 1

21/3*19==3/19*21

Varianta 2

21/19*3==19/3*21

Varianta 3

19/3*21==3/21*19

Varianta 4

19/21*3==3/19*21

Subiect simulare Bacalaureat 2019
Clasa a 9-a

Exercițiul #16

Variabilele x şi y sunt de tip întreg, x memorând valoarea 8, iar y valoarea 6. Care dintre expresiile C/C++ de mai jos are valoarea 0?

Varianta 1

3*x-4*y==0

Varianta 2

(x+y)/2 > x%y+1

Varianta 3

!(x/2+2==y)

Varianta 4

x-y+3!=0

Variante Bacalaureat 2009
Clasa a 9-a