Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 419

Exercițiul #820

Indicați o expresie C/C++ care are valoarea 1 dacă și numai dacă numărul întreg memorat în variabila întreagă x aparține mulțimii {-2,-1,1,2}.

Varianta 1

abs(x)>2 || x==0

Varianta 2

abs(x)<=2 && x!=0

Varianta 3

abs(x-2)<1

Varianta 4

abs(x-1)>2

Subiect Bacalaureat 2016, SN
Clasa a 9-a

Exercițiul #800

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a, iar cu sqrt(x) rădăcina pătrată a numărului pozitiv x.

citeşte a,b
   (numere naturale, a≤b) 
 s←0 
┌pentru x←a,b execută
│┌pentru j←1,[x/2] execută
││┌dacă x%j=0 și [sqrt(j)]*[sqrt(j)]=j atunci 
│││ s←s+j 
││└■
│└■
└■
scrie s 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 11 și 16.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #799

Variabila x este de tip întreg. Numărul de valori întregi distincte ale lui x pentru care expresia C/C++ x/2017 are valoarea 0 este:

Varianta 1

2016

Varianta 2

2017

Varianta 3

2•2016+1

Varianta 4

2•2017+1

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #798

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b.

citeşte a,b
   (numere naturale, a≥2, b≥2) 
┌dacă a>b atunci 
│ x←a  
│ a←b 
│ b←x 
└■
 s←0 
┌pentru x←a,b execută
│ c←2 
│┌cât timp x%c>0 execută
││ c←c+1 
│└■
│s←s+c 
└■
scrie s 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 7, 4.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #797

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
    (număr natural nenul) 
┌pentru i←1,n execută
│┌pentru j←1,n execută
││┌dacă i=j sau i+j=n+1 atunci 
│││ scrie ’#’ 
│││altfel 
│││ scrie j 
││└■
│└■
└■

Scrieți un număr care poate fi citit, astfel încât, în urma executării algoritmului numărul de simboluri # afișate să fie 100.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #796

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
    (număr natural nenul) 
┌pentru i←1,n execută
│┌pentru j←1,n execută
││┌dacă i=j sau i+j=n+1 atunci 
│││ scrie ’#’ 
│││altfel 
│││ scrie j 
││└■
│└■
└■

Scrieți ce se afișează dacă se citește numărul 3.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #194

Variabila a memorează un tablou bidimensional cu 5 linii și 5 coloane, numerotate de la 1 la 5, ale cărui elemente sunt numere întregi. Care este cea mai mare valoare, memorată în tablou, deasupra diagonalei principale a tabloului construit în urma executării secvenţei de program de mai jos?

for(i=1;i<=5;i++)
  for(j=1;j<=5;j++)
    a[i][j]=j%i+i%j;
Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #791

Indicaţi expresia C/C++ care are valoarea 1 dacă şi numai dacă numărul natural memorat în variabila întreagă x are exact o cifră.

Varianta 1

x%10==x

Varianta 2

x/10==x

Varianta 3

x%10==x/10

Varianta 4

(x%10)/10==x

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #203

Variabila a memorează elementele unui tablou bidimensional cu 5 linii şi 5 coloane(numerotate de la 1 la n), numere întregi. Care este suma elementelor aflate pe diagonala secundară a tabloului construit în urma executării secvenţei de program de mai jos?

for(i=1;i<=5;i++)
  for(j=1;j<=5;j++)
    a[i][j]=i-j;
Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #205

În secvenţa de mai jos, variabila v memorează elementele unei matrice cu liniile şi coloanele numerotate de la 1 la n, iar toate celelalte variabile sunt întregi. Dacă 1≤k<n, atunci executarea secvenţei determină:

for ( i=k+1; i<=n; i++)
  for (j=1; j<=n; j++)
    v[i-1][j] = v[i][j];
n=n-1;
Varianta 1

eliminarea liniei k din matrice

Varianta 2

adăugarea liniei k în matrice

Varianta 3

eliminarea coloanei k din matrice

Varianta 4

adăugarea coloanei k în matrice

Variante Bacalaureat 2009
Clasa a 9-a