Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 458

Exercițiul #13

Fiecare dintre variabilele întregi x şi y memorează câte un număr natural. Care dintre expresiile C/C++ de mai jos are valoarea 1 dacă şi numai dacă numărul memorat în x este strict mai mare decât 0 şi numărul memorat în y este strict mai mare decât 5?

Varianta 1

x*y-5!=0

Varianta 2

x*(y-5)!=0

Varianta 3

x*(y-5)>=0

Varianta 4

!(x*(y-5)<=0)

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #35

Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă numărul natural nenul memorat în variabila x, de tip int, este divizibil cu 100?

Varianta 1

x%10+x/10%10==0

Varianta 2

x/100==0

Varianta 3

x%10+x/10==0

Varianta 4

x%10+x%10/10==0

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #55

Variabila a, de tip int, memorează un număr natural impar, iar variabila b, de tip int, memorează un număr natural par. Care dintre următoarele expresii C/C++ are valoarea 1?

Varianta 1

a%2 && b%2

Varianta 2

!(!(a%2) || b%2)

Varianta 3

(a+b+1)%2

Varianta 4

!(a%2) || b%2

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #660

Variabila x este de tip întreg. Indicaţi o expresie C/C++ care are valoarea 1 dacă şi numai dacă valoarea variabilei x are exact trei cifre.

Varianta 1

x%1000==0 || x%100!=0

Varianta 2

x/1000==0 || x/100!=0

Varianta 3

x%1000==0 && x%100!=0

Varianta 4

x/1000==0 && x/100!=0

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #488

Expresia C/C++ 4+5%7*2 are valoarea:

Varianta 1

4

Varianta 2

8

Varianta 3

9

Varianta 4

14

Subiect Bacalaureat 2015
Clasa a 9-a

Exercițiul #810

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a.

citeşte n 
    (număr natural nenul)
 p←0 
┌pentru i←1,n execută
│ m←i 
│┌cât timp m%2=0 execută
││ m←[m/2] 
│└■
│┌dacă m=1 atunci 
││ p←i 
│└■
└■
 scrie p 

Scrieți valoarea afișată în urma executării algoritmului dacă se citește numărul 12.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #203

Variabila a memorează elementele unui tablou bidimensional cu 5 linii şi 5 coloane(numerotate de la 1 la n), numere întregi. Care este suma elementelor aflate pe diagonala secundară a tabloului construit în urma executării secvenţei de program de mai jos?

for(i=1;i<=5;i++)
  for(j=1;j<=5;j++)
    a[i][j]=i-j;
Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #519

Variabila i este de tip întreg (0≤i≤99), iar variabila a memorează elementele unui tablou bidimensional cu 100 de linii şi 100 de coloane, numerotate de la 0 la 99. În limbajul C/C++, un element aflat pe linia i și pe diagonala principală a tabloului poate fi accesat prin:

Varianta 1

a[i,i]

Varianta 2

a(i,i)

Varianta 3

a(i)(i)

Varianta 4

a[i][i]

Subiect Bacalaureat 2013
Clasa a 9-a

Exercițiul #986

Pentru a putea memora un tablou bidimensional cu maximum 21 de elemente, numere reale, variabila A se poate declara astfel:

Varianta 1

A[3..7] int;

Varianta 2

A[3][7] float;

Varianta 3

int A[3;7];

Varianta 4

float A[3][7];

Subiect Bacalaureat 2014, sesiunea specială
Clasa a 9-a

Exercițiul #1051

Pentru a verifica dacă într-un tablou unidimensional există elementul cu valoarea x=0, se aplică metoda căutării binare, iar succesiunea de elemente ale tabloului a căror valoare se compară cu valoarea lui x pe parcursul aplicării metodei indicate este: 20, 2, 0. Indicați succesiunea de valori care pot fi, în această ordine, elementele tabloului.

Varianta 1

(0,1,2,4,20,40,64)

Varianta 2

(0,2,4,8,16,20,32)

Varianta 3

(0,2,20,0,4,40,0,8,80)

Varianta 4

(0,2,4,20,30,32,40)

Subiect Bacalaureat 2020, sesiunea august-septembrie, Științele-naturii
Clasa a 9-a