Exerciții

Căutare

Filtrare

?
exerciții corespund restricțiilor

Rezultate 557

Exercițiul #11

Variabila x este de tip real. Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă numărul real memorat în variabila x nu aparţine intervalului (2,9]?

Varianta 1

(x>2) && (x<=9)

Varianta 2

(x<=2) && (x>9)

Varianta 3

(x<=2) || (x>9)

Varianta 4

(x<2) || (x>9)

Variante Bacalaureat 2009 Clasa a IX-a

Exercițiul #33

În expresia C/C++ x%2+(x+1)%2 variabila x este de tip întreg. Această expresie:

Varianta 1

are valoarea 1 pentru orice număr natural x.

Varianta 2

are valoarea 1 dacă şi numai dacă x este un număr par.

Varianta 3

are valoarea 1 dacă şi numai dacă x este un număr impar.

Varianta 4

are o valoare strict mai mare decât 1 pentru orice număr natural x.

Variante Bacalaureat 2009 Clasa a IX-a

Exercițiul #53

Care dintre următoarele variabile nu îşi modifică valoarea în urma executării secvenţei de instrucţiuni de mai jos, oricare ar fi valorile lor iniţiale? (a, b, c sunt variabile de tip int).

c=2*a-b;
a=a-b; a=c-a;
b=2*a-c;
Varianta 1

niciuna

Varianta 2

doar c

Varianta 3

doar a și c

Varianta 4

doar a și b

Variante Bacalaureat 2009 Clasa a IX-a

Exercițiul #786

Indicaţi expresia C/C++ care are valoarea 1 dacă şi numai dacă numărul natural memorat în variabila întreagă x are exact trei cifre.

Varianta 1

x/1000==0 && x/100!=0

Varianta 2

x/1000==0 || x/100!=0

Varianta 3

x%1000==0 && x%100!=0

Varianta 4

x%1000==0 || x%100!=0

Subiect Bacalaureat 2017 Clasa a IX-a

Exercițiul #498

Valoare expresiei C/C++ 42/10*29/10 este:

Varianta 1

6

Varianta 2

8

Varianta 3

11

Varianta 4

18

Subiect Bacalaureat 2014, sesiunea iunie-iulie Clasa a IX-a

Exercițiul #800

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a, iar cu sqrt(x) rădăcina pătrată a numărului pozitiv x.

citeşte a,b
   (numere naturale, a≤b) 
 s←0 
┌pentru x←a,b execută
│┌pentru j←1,[x/2] execută
││┌dacă x%j=0 și [sqrt(j)]*[sqrt(j)]=j atunci 
│││ s←s+j 
││└■
│└■
└■
scrie s 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 11 și 16.

Subiect Bacalaureat 2017 Clasa a IX-a

Exercițiul #147

Într-un tablou bidimensional A, cu n linii şi n coloane, notăm cu Aij elementul aflat pe linia i şi coloana j (1≤i≤n, 1≤j≤n). Care este valoarea expresiei j+i dacă elementul Aij este situat pe diagonala secundară a tabloului A?

Varianta 1

n

Varianta 2

n-1

Varianta 3

n+1

Varianta 4

2*n

Variante Bacalaureat 2009 Clasa a IX-a

Exercițiul #367

În secvenţa următoare, i, j şi n sunt variabile întregi, iar a este o matrice pătratică formată din n linii şi n coloane numerotate de la 0 la n-1. Care este suma elementelor de pe diagonala principală din matricea a, în urma executării acestei secvenţe, dacă n=8?

for(i=0; i<n; i++)
  for(j=0; j<n; j++)
    a[i][j] = (i+j)%n;
Varianta 1

8

Varianta 2

64

Varianta 3

24

Varianta 4

56

Variante Bacalaureat 2009 Clasa a IX-a

Exercițiul #821

Variabilele x, y și d sunt de tip întreg și memorează câte un număr natural strict pozitiv. Indicați o expresie care poate înlocui punctele de suspensie astfel încât, în urma executării secvenței obținute, variabila d să memoreze cel mai mare divizor comun al valorilor memorate în variabilele x și y.

d=x;
if(d>y) d=y; 
while(........) 
    d=d-1;
Varianta 1

(x%d)*(y%d)!=0

Varianta 2

(x+y)%d!=0

Varianta 3

x%d!=y%d

Varianta 4

x%d+y%d!=0

Subiect Bacalaureat 2016, SN Clasa a IX-a

Exercițiul #1062

În secvența de mai jos toate variabilele sunt de tip întreg și memorează numere naturale.

y=1; x=10; n=8; 
while(n>0)
  if(n%2==0)
  { x=x*x;
    n=.......;  
  }
  else
  { y=y*x;
    n=n-1;
  }

Indicați expresia care poate înlocui punctele de suspensie astfel încât, în urma executării secvenței obținute, variabila y să memoreze valoarea 108.

Varianta 1

n/2

Varianta 2

n/2-1

Varianta 3

n/2+1

Varianta 4

n+1

Subiect Bacalaureat 2020, sesiunea iunie-iulie, Științele-naturii Clasa a IX-a