Exerciții

Căutare

Filtrare

?
exerciții corespund restricțiilor

Rezultate 611

Exercițiul #18

Care dintre expresiile C/C++ de mai jos este echivalentă cu expresia următoare !((a<5)&&(b>7)) ?

Varianta 1

(a>=5)&&(b<=7)

Varianta 2

!(a<5) || !(b>7)

Varianta 3

!(a<5) && !(b>7)

Varianta 4

!(a>=5) && !(b<=7)

Variante Bacalaureat 2009 Clasa a IX-a

Exercițiul #39

Variabila a memorează un număr natural care are exact 3 cifre. Care dintre expresiile C/C++ de mai jos are ca valoare numărul format din prima şi ultima cifră a numărului memorat de a?

Varianta 1

a/10+a%100

Varianta 2

a/100+a%10

Varianta 3

a/100*10+a%10

Varianta 4

a-a/10%10

Variante Bacalaureat 2009 Clasa a IX-a

Exercițiul #59

Variabila întreagă x memorează un număr natural. Care dintre următoarele expresii C/C++ are valoarea 0 dacă şi numai dacă numărul memorat de x NU este divizibil cu 3?

Varianta 1

x%3

Varianta 2

(1-x%3)+(2-x%3)

Varianta 3

(1-x%3)*(2-x%3)

Varianta 4

3-x%3

Variante Bacalaureat 2009 Clasa a IX-a

Exercițiul #555

Indicați care dintre expresiile C/C++ de mai jos are valoarea 1 dacă şi numai dacă numărul natural memorat în variabila întreagă n este divizibil cu 2 şi cu 7.

Varianta 1

!( (n%2==1) || (n%7!=0) )

Varianta 2

(n%2==0) && (n%7!=0)

Varianta 3

(n%2==0) || !(n%7==0)

Varianta 4

(n%7==2) && (n%2==7)

Subiect Bacalaureat 2010 Clasa a IX-a

Exercițiul #25

Câte atribuiri se execută, în total, în secvenţa de mai jos, dacă n şi p sunt variabile de tip întreg?

p=1; n=279;
while (n>=100)
{ p=p*10;
 n=n-100;
}
Varianta 1

4

Varianta 2

6

Varianta 3

2

Varianta 4

8

Variante Bacalaureat 2009 Clasa a IX-a

Exercițiul #654

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
(număr natural nenul)
k ← 1
m ← 1
┌cât timp n>9 execută
│┌dacă n%10=[n/10]%10 atunci
││ k ← k+1
││┌dacă k>m atunci
│││ m ← k
││└■
││altfel
││ k ← 1
│└■
│ n ← [n/10]
└■
scrie m

S-a notat cu a%b restul împărţirii numărului natural a la numărul natural nenul b şi cu [c] partea întreagă a numărului real c.

Scrieţi numărul de valori din intervalul [10000,99999] care să înceapă cu cifra 1, care pot fi citite pentru variabila n, astfel încât, în urma executării algoritmului, pentru fiecare dintre acestea, să se afişeze valoarea 4.

Subiect Bacalaureat 2016 Clasa a IX-a

Exercițiul #219

În secvenţa de mai jos, variabila a memorează elementele unui tablou bidimensional cu 4 linii (numerotate de la 0 la 3) şi 4 coloane (numerotate de la 0 la 3), iar toate celelalte variabile sunt de tip întreg.

x=1;
for (i=0;i<=3;i++)
  for (j=0;j<=3;j++)
  {
    if (i==j)
      a[i][j]=2*x;
    else a[i][j]=x;
    x=x+1;
  }

Care este suma elementelor de pe diagonala principală a acestui tablou după executarea acestei secvențe de instrucțiuni?

Variante Bacalaureat 2009 Clasa a IX-a

Exercițiul #977

În secvențele de mai jos, notate cu S1, S2 și S3, toate variabilele sunt întregi, iar variabila n memorează un număr natural cu cel mult nouă cifre.

//S1
if(n==0) p=1; 
else 
  if (n%2==0) p=6; 
  else p=4;
//S2
p=1; 
for(i=1;i<=n;i++) 
  p=(p*4)%10;
//S3
p=1; 
for(i=1;i<=n;i++) 
  p=(p%10)*4;

Variabila p memorează ultima cifră a numărului 4n în urma executării, independent, a secvențelor:

Varianta 1

S1 și S2

Varianta 2

S1 și S3

Varianta 3

S2 și S3

Varianta 4

S1, S2 și S3

Subiect Bacalaureat 2018, sesiunea iunie-iulie, științele naturii Clasa a IX-a

Exercițiul #1179

Variabilele x și y sunt de tip întreg și memorează numere naturale nenule. Indicați o expresie C/C++ care are valoarea 1 dacă și numai dacă numărul memorat în x are cifra zecilor egală cu 2 și este un multiplu al numărului memorat în y.

Varianta 1

x/10%10==2 && x%y==0

Varianta 2

x/10%10==2 || y%x==0

Varianta 3

x/2%10==10 && x%y==0

Varianta 4

x/2%10==10 || y%x==0

Teste antrenament Bacalaureat 2021 Clasa a IX-a

Exercițiul #1205

Tablourile unidimensionale A și B au valorile A=(18,15,9,5,1) și B=(40,15,13,4,1). Pentru a determina al 5-lea element obținut în urma interclasării tablourilor în ordine crescătoare, se compară elementul cu valoarea xa din A cu elementul cu valoarea xb din B. Indicați valorile lui xa și xb.

Varianta 1

xa=5 și xb=4

Varianta 2

xa=5 și xb=13

Varianta 3

xa=9 și xb=4

Varianta 4

xa=9 și xb=13

Teste antrenament Bacalaureat 2021 Clasa a IX-a