Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 552

Exercițiul #12

Care dintre următoarele expresii C/C++ are ca valoare cel mai mic dintre numerele naturale nenule, cu cel mult 4 cifre fiecare, memorate în variabilele întregi x şi y?

Varianta 1

(x+y-abs(x-y))/2

Varianta 2

x+y-abs(x-y)/2

Varianta 3

(x+y+abs(x-y))/2

Varianta 4

(x+y+abs(x+y))/2

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #34

Câte valori distincte, numere naturale, poate primi variabila x pentru ca valoarea expresiei x/2/2 scrisă în C/C++ să fie egală cu 1?

Varianta 1

1

Varianta 2

4

Varianta 3

2

Varianta 4

0

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #54

Variabilele a, b şi c, de tip int, pot fi iniţializate cu oricare numere naturale impare distincte. Ştiind că c este divizor al lui a, iar b nu este multiplu al lui c, care dintre următoarele expresii scrise în C/C++ are valoare 1?

Varianta 1

!((a % c!=0) || !(b % c!=0))

Varianta 2

(a % c!=0) && !(b % c!=0)

Varianta 3

(a % c!=0) || !(b % c!=0)

Varianta 4

!(c % a!=0) && (c % b!=0)

Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #709

Variabilele x și y sunt de tip real. Expresia C/C++ de mai jos este echivalentă cu expresia:

!(x>0 && y>0)
Varianta 1

x<=0 || y<=0

Varianta 2

x<=0 && y<=0

Varianta 3

x>0 || y>0

Varianta 4

!(x>0) && !(y>0)

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #493

Variabilele x, y și z sunt de tip întreg și memorează câte un număr natural nenul. Dacă expresia C/C++ !(z<=y) && y>x are valoarea 1, indicați șirul crescător format cu valorile acestor variabile, în ordinea precizată mai jos.

Varianta 1

x, y, z

Varianta 2

y, z, x

Varianta 3

z, x, y

Varianta 4

z, y, x

Subiect Bacalaureat 2014
Clasa a 9-a

Exercițiul #806

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a, iar cu sqrt(x) rădăcina pătrată a numărului pozitiv x.

citeşte n 
   (număr natural nenul) 
 k←0 
 i←1 
┌cât timp i≤n execută
│ citeşte x  
│   (număr natural nenul) 
│ y←2  
│┌cât timp x>1 și x%y≠0 execută
││ y←y+1 
│└■
│┌dacă k<[x/y] atunci 
││ k←[x/y] 
│└■
│ i←i+1  
└■
 scrie k 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 4, 5, 24, 3, 45.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #194

Variabila a memorează un tablou bidimensional cu 5 linii și 5 coloane, numerotate de la 1 la 5, ale cărui elemente sunt numere întregi. Care este cea mai mare valoare, memorată în tablou, deasupra diagonalei principale a tabloului construit în urma executării secvenţei de program de mai jos?

for(i=1;i<=5;i++)
  for(j=1;j<=5;j++)
    a[i][j]=j%i+i%j;
Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #510

Variabila a memorează elementele unui tablou bidimensional cu 100 de linii şi 100 de coloane, numerotate de la 1 la 100. Un element aflat pe diagonala secundară a tabloului poate fi accesat prin:

Varianta 1

a[1][3]

Varianta 2

a[15][15]

Varianta 3

a[16][24]

Varianta 4

a[42][59]

Subiect Bacalaureat 2013
Clasa a 9-a

Exercițiul #1050

Tablourile unidimensionale A și B au elementele: A=(2,22,25,32,48), iar B=(3,5,8,45,60). Indicați succesiunea de valori care pot fi, în această ordine, elementele tabloului obținut în urma interclasării lui A și B în ordine crescătoare.

Varianta 1

(2,5,8,32,48)

Varianta 2

(2,3,5,8,22,25,32,45,48,60)

Varianta 3

(2,3,5,22,8,25,32,45,48,60)

Varianta 4

(2,22,25,32,48,3,5,8,45,60)

Subiect Bacalaureat 2020, sesiunea august-septembrie, Științele-naturii
Clasa a 9-a

Exercițiul #822

Tablourile unidimensionale A și B au elementele: A=(20,17,12,10,3), iar B=(45,16,12,7,2) . În urma interclasării lor în ordine descrescătoare se obține tabloul cu elementele:

Varianta 1

(45,17,12,10,3)

Varianta 2

(45,20,16,17,12,12,7,10,2,3)

Varianta 3

(45,20,17,16,12,12,10,7,3,2)

Varianta 4

(45,20,17,16,12,12,7,10,3,2)

Subiect Bacalaureat 2016, SN
Clasa a 9-a