Exerciții

Căutare

Filtrare

Etichete

?
exerciții corespund restricțiilor

Rezultate 431

Exercițiul #918

Variabilele x și y sunt de tip întreg și memorează câte un număr natural nenul. O expresie echivalentă cu !(x%y!=0||y<2) poate fi:

Varianta 1

x%y==y%x && y>1

Varianta 2

(x+y)%y==0 || y >= 1

Varianta 3

(x/y)*y==x && y>=2

Varianta 4

x%y==0 || y>2

Subiect Bacalaureat 2018, sesiunea iunie-iulie
Clasa a 9-a

Exercițiul #156

În secvenţa de mai jos, variabilele i şi j sunt de tip întreg, iar variabila a memorează o matrice în care prima linie şi prima coloană sunt numerotate cu 1. Toate elementele matricei primesc valori în urma executării secvenţei.

Scrieţi în ordine, începând cu prima linie, separate prin exact un spațiu, doar elementele situate pe cea de-a treia coloană a matricei.

for(j=1;j<=6;j++)
  for(i=1;i<=4;i++)
    a[i][j]=2*i+j;
Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #157

În secvenţa de mai jos, variabilele i şi j sunt de tip întreg, iar variabila a memorează o matrice în care prima linie şi prima coloană sunt numerotate cu 0. Toate elementele matricei primesc valori în urma executării secvenţei.

Scrieţi în ordine, începând cu prima linie, separate prin exact un spațiu, doar elementele situate pe cea de-a treia coloană a matricei.

for(j=0;j<6;j++)
  for(i=0;i<4;i++)
    a[i][j]=2*i+j;
Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #810

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a.

citeşte n 
    (număr natural nenul)
 p←0 
┌pentru i←1,n execută
│ m←i 
│┌cât timp m%2=0 execută
││ m←[m/2] 
│└■
│┌dacă m=1 atunci 
││ p←i 
│└■
└■
 scrie p 

Scrieți valoarea afișată în urma executării algoritmului dacă se citește numărul 12.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #161

În secvenţa de mai jos, variabilele i şi j sunt de tip întreg, iar variabila a memorează o matrice în care prima linie şi prima coloană sunt numerotate cu 1. Toate elementele matricei primesc valori în urma executării secvenţei.

Scrieţi în ordine, începând cu prima coloană, separate prin exact un spațiu, doar elementele situate pe cea de-a doua linie a matricei.

for(j=1;j<=6;j++)
  for(i=3;i>=1;i--)
    a[i][j]=i+j;
Variante Bacalaureat 2009
Clasa a 9-a

Exercițiul #654

Se consideră algoritmul de mai jos, reprezentat în pseudocod.

citeşte n
(număr natural nenul)
k ← 1
m ← 1
┌cât timp n>9 execută
│┌dacă n%10=[n/10]%10 atunci
││ k ← k+1
││┌dacă k>m atunci
│││ m ← k
││└■
││altfel
││ k ← 1
│└■
│ n ← [n/10]
└■
scrie m

S-a notat cu a%b restul împărţirii numărului natural a la numărul natural nenul b şi cu [c] partea întreagă a numărului real c.

Scrieţi numărul de valori din intervalul [10000,99999] care să înceapă cu cifra 1, care pot fi citite pentru variabila n, astfel încât, în urma executării algoritmului, pentru fiecare dintre acestea, să se afişeze valoarea 4.

Subiect Bacalaureat 2016
Clasa a 9-a

Exercițiul #498

Valoare expresiei C/C++ 42/10*29/10 este:

Varianta 1

6

Varianta 2

8

Varianta 3

11

Varianta 4

18

Subiect Bacalaureat 2014, sesiunea iunie-iulie
Clasa a 9-a

Exercițiul #806

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a, iar cu sqrt(x) rădăcina pătrată a numărului pozitiv x.

citeşte n 
   (număr natural nenul) 
 k←0 
 i←1 
┌cât timp i≤n execută
│ citeşte x  
│   (număr natural nenul) 
│ y←2  
│┌cât timp x>1 și x%y≠0 execută
││ y←y+1 
│└■
│┌dacă k<[x/y] atunci 
││ k←[x/y] 
│└■
│ i←i+1  
└■
 scrie k 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 4, 5, 24, 3, 45.

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #805

Expresia C/C++ 3+7/4+3 are valoarea:

Varianta 1

1

Varianta 2

5.5

Varianta 3

7

Varianta 4

7.75

Subiect Bacalaureat 2017
Clasa a 9-a

Exercițiul #800

Se consideră algoritmul de mai jos, reprezentat în pseudocod. S-a notat cu a%b restul împărțirii numărului natural a la numărul natural nenul b, cu [a] partea întreagă a numărului real a, iar cu sqrt(x) rădăcina pătrată a numărului pozitiv x.

citeşte a,b
   (numere naturale, a≤b) 
 s←0 
┌pentru x←a,b execută
│┌pentru j←1,[x/2] execută
││┌dacă x%j=0 și [sqrt(j)]*[sqrt(j)]=j atunci 
│││ s←s+j 
││└■
│└■
└■
scrie s 

Scrieți valoarea afișată dacă se citesc, în această ordine, numerele 11 și 16.

Subiect Bacalaureat 2017
Clasa a 9-a